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Top 20 Microsoft Project Interview Question
& Answers
1) Explain what is link task in MS project used for?
As the name suggests, link task in MS project is used for linking any two tasks in a project.
2) Mention where is “summary task” in MS project?
Summary task is helpful in estimating the task period and the length in project, and organizing the
task in order. You can ﬁnd “summary task” under main menu -> Insert -> Summary
3) List out the categories of tasks used in MS project?
There are major four types of tasks:
Summary tasks: It consists of subtasks and their related properties
Subtasks: It is a smaller task that are part of a summary task
Recurring tasks: These are the tasks that falls at regular intervals
Milestones: These are the prime priority task that are adjusted to zero duration and are like
short-term goals in the project
4) Mention what are the new features available in MS project 2013?
Improved reporting tools: MS project 2013 offers advanced reporting tools and easy
accountability for organizations
Office 365 Integration: Easy integration of office 365 to the MS project data
New Project Templates: The new MS project provides project templates that can be
compliance to your requirement like marketing, construction, business, software development
plan, etc.
Better Presentation Tools: The timeline view gives better view of the progress of your
project and helps to schedule your project accordingly
Task Path: This feature can be handy for a project manager handling large and complex
schedules. It allows the user to see the path for a specific task including Successors, Driven
successors, Predecessors and Driving Predecessors.
5) Explain what is a constraint in MS project? What are the types of constraint available in
MS project 2013?
In MS project, constraint is used for scheduling the task and setting a due date for the task. The types
of constraint available in MS project are
As soon as possible
As late as possible
Must start on
Must finish on

Finish no later than
Start no later than
Start no earlier than
Finish no earlier than

6) Mention how to set a deadline in MS project?
To set a deadline in MS project
Double-click a task -> it will open a task information dialog box
Now, click on the advanced tab
Then click on the arrow in the deadline field to show the calendar and then choose a date
Now save this by clicking on the save button
7) Explain how you can move tasks in project 2013?
You can move tasks in MS project 2013 by two techniques
Move the task with drag and drop method
Move the task with the cut and paste method
8) Explain how you can remove resource from your project?
To remove the resource from your project, ﬁrst ﬁlter the task list to view only the tasks to which the
resource is allocated, and then you can edit or change each task to replace that resource.
Choose a task-oriented view like Gantt chart and hide the summary tasks, this list will show
only work tasks and milestones
Under View tab’s data section, click on the filter drop-down list and then select “Using
Resource.”
In the “show tasks using” drop-down list, select the resource and delete it that you don’t want
and then click ok
To replace the resource, select “Assign Resources” under resource tab’s assignment section.
Select the task from the table you want to re-assign, and then, in the Assign resource dialog
box, choose the resource you want to replace and click replace
Click the format tab, and turn the checkbox back on for “Show Summary Tasks.”
Click resource sheet in the view tab’s resource view section and now you can delete the

resource
9) Mention what is the characteristics of Gantt Chart Basics?
In Gantt chart, each task is displayed by one row
Dates are displayed in incremental order like days, weeks or months as per the total length of
the project
For each task expected, time is displayed by a horizontal bar whose left end indicates the
estimated beginning of the task and right end indicates the estimated completion date
Task may run parallel, sequentially or overlapping
The chart is represented in the bar formation to a length proportional to the fraction of the
work that has been completed
On the left of the line, you will see the completed tasks
Future tasks line lies to the right of the line
Current task are cross the line and are behind schedule when filled in section is on the left of
the line and ahead of schedule when it is right of the line
10) Explain what is the use of work contour in MS project? What are the diﬀerent types of
contour you use in MS project?
In MS project work, contour displays the distribution of working hours over the duration of the task.
The graph will show the peak according the work distribution over the week.
Flat: Such contour signifies an even distribution of work
Back-loaded: It will show the peak activity at the end of the project
Front-loaded: It will show the peak working activity at the opening of the project
Double peak: It will show two major periods of peak activity
Early peak: It is same as the front loaded but with the rise to peak activity
Late peak: It is same as a back loaded contour with a ramp
Bell: It shows a single peak in the central of the project
Turtle: A bell with a ramp up and down
11) Explain how you can format a Gantt chart on MS project?
To format a Gantt chart on MS project
First you have to click on Format icon from main menu bar
Click customize quick access toolbar, which is last on the corner above menu bar
-> click on more components -> select on, comments not in pattern
-> click on Gantt Chart Wizard and then click add and ok
Once Gantt chart wizard setup, it will open a window that displays various setting like
standard, critical path, baseline and other for your Gantt chart. You can select option
according to requirement and click next
Likewise, you can also set information like resources and dates, resources or dates alone
Once you exit wizard, basic formatting like color, font size and appearance can be changed
from the main menu ( FORMAT) itself
12) Explain how you can link tasks in MS project 2013?
You can link or connect any two tasks in a project to manifest their relationship, also referred as
dependency. Dependency drives the project schedule and once you change the tasks, every change
you make to one alter the task of other, which aﬀects the next and so on. To link the task, you have
to

Click View -> Gantt Chart
Hold down Cntrl and click the two tasks you want to link
Click on Task -> Linked the selected tasks
13) Mention the types of task links in MS project 2013?
There are four types of task links in MS project
Finish to start link: In this link the second task cannot be initiated until the first task is
completed
Start to start link: In this link, the second task can begin at any time after first task is
initiated
Finish to finish link: In this link, two task does not have to end at the same time, the second
task can end anytime after first task is ended
Start to finish link: In this link, the second task can’t finish until the first task begins.
14) Explain what is resource levelling?
Resource levelling is the coolest feature given by MS project; these tool schedules work without over
allocating work to the employees, especially for those who are indulged in multi-task activities. For
example, there is a project A and B and allotted time for this project is 3 and 2 days. When an
individual use resource levelling, it schedule the work as ﬁrst 2 days for the project A and later two
days for project B and again on the last day it will return to project A.
15) Explain how you can create and code a WBS (Work Breakdown Structure) in MS
project?
Inserting Tasks: If you forgot to insert task in the list you can add by clicking the place whee
you want to add a task and go to “Insert>New” task or press “insert.”
Outlining Structure: You will be creating an outline of the project by assigning the project
name. In respect to do that you have to select all deliverables underneath the heading and
then click the Indent button. They will all line up, and the deliverable will appear in bold
Assign numerical code to tasks: Once you have created a work breakdown, you can assign
a numerical code to it. In respect to do that go to “tools” in the task bar. Under “options”, you
will see “outline options”, under this you have to click on check box with the option “show
outline number”. You will see that the task list will have a numerical code in front of it.
16) What should you be aware of before importing excel ﬁle to MS project?
Before you import excel ﬁle, you should be aware of following things
Make sure which excel file fields will be mapped to which MS project
Not necessary that all fields in the excel should be imported to MS project, you have the
opportunity to choose the field you wanted to import
Make sure that your import file has a column header
Blank fields in the excel will be imported as a blank field the project
Start and finish date in excel will be imported in the MS project start and finish field as start
no earlier than constraints for the tasks
If the map has to imported then, it should in Global.mpt file format on your machine, if it is not
in that format then import wizard will nod show the map as selection choice.
17) Explain the path for importing excel into the MS project 2013?
Path for importing the ﬁle into MS project:

File -> Open -> Files of type -> Excel workbook -> browse the file and select the file -> Now
click on Open -> Wizard will start -> Click Next
At the end of the run wizard, it will ask how you want to import the ﬁle
As a new project
Append the data to the active project
Merge the data into the active project
After selecting any of the above options, you can click next to ﬁnish importing excel ﬁle to MS
project.
18) Explain how you can compare budget resource values in MS project?
Go to Resource Usage view ( View -> Resource Usage)
Add budget cost, Work, budget work and Cost columns to the table if they are not there
already
Tap on the drop down arrow to the right of the Resource Name column heading and then
choose “Group by” -> Custom group, in order to group the resource by custom resource test
field
Tap on the down arrow in the Field Name cell in the Group By row section, after that in the
drop down list of resource fields, select the name of the custom text field for your budget
categories and then click apply
Now in the group summary rows, compare the budget get cost or budget work values to the
cost or work values simultaneously
To dismantle the group, you can choose NO groups by clicking down arrow to the right of the
Resource Name column heading
19) Explain what are the setting you have to insert while entering Project Information into
Project 2013?
To enter project information into project 2013, it includes information like
Start and Finish Date: For a project that is scheduled forward from the start date, enter only
the start date, while enter the finish date if you like to schedule backward from finish date
Schedule From: You can select the finish date or start date whichever way you want to
schedule your task
Current Date: By default this setting matches the computer clock settings; however it can be
configured according to your requirement
Status Date: To track the progress on the project you can the current date status. This will
show the status of the project as of the current moment
Calendar: From this drop-down list you can choose the base calendar template to use for the
project calendar
Priority: By using this field you can prioritize your work and decide which work has to be
delayed and which has to be done immediately
20) Explain how to set work time exception in Project 2013?
To alter the available working hours in Project 2013 for a particular day, you have to change the work
time exception settings. In order to do that
Select the project and change the working time
On the calendar choose the day you want to change
Click the exception tab to display it, it will show a column with the name cell in a blank row,

type a name for the exception and press enter
Tap the exception name you entered in step 3 and then click the details button. It will open a
detail dialog box for this exception. Where you will make the setting according to your
requirement like working time, recurrent pattern and range of recurrence.
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